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Preface
1.1 Introduction
This document gives an overview of XLFiX and its uses. The tool is delivered as a
COM Add-in for Excel and provides Excel with FIX functionality. It can be used for
parsing FIX messages to and from Excel spreadsheets. Messages can be sent and
received directly to and from Excel. The tool can be configured to match your specific
implementation (including any user defined content). This product includes software
developed by quickfixengine.org http://www.quickfixengine.org/

1.2 Intended Audience
This document is intended for users of XLFiX. It covers the aspects of setting up
Microsoft Excel for use with FIX.

1.3 Abbreviations
Table 1 provides a description for each abbreviation used in the document:
Abbreviation
COM
FIX
IP

Description
Component Object Model
Financial Information Exchange
Internet Protocol
Table 1

1.4 System Requirements
The XLFiX COM Add- in is compatible with Excel 2000 or later running on Windows
NT 4, Windows 2000 or Windows XP. It also requires the "Microsoft .Net
Framework 1.1 Redistributable" package to be installed on the PC. This is freely
available from the Microsoft website:
http://msdn.microsoft.com/netframework/technologyinfo/howtoget/default.aspx
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2 Installation and Removal
2.1 Installing XLFiX
Open the zip file and double click the Setup.exe file. A welcome page will appear.
Click the “Next” button in the bottom right hand corner.

Figure 1

Enter the path for the installation (see Figure 1), then click the “Next” button. The
package will take a few seconds to install. Now you’re ready to go… start Excel and
you will see the XLFiX menu on Excel’s main menu bar.

2.2 Removing XLFiX
The package can be removed using “Add or Remove Programs” from the Windows
Control Panel (see Figure 2).

Figure 2
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3 Getting Started – XLFiX Menu
The main menu can be found on the Excel menu bar (see Figure 3).

Figure 3

3.1 FIX Session Manager
The Session Manager allows you to setup and control FIX sessions with the minimum
of fuss. Multiple sessions can be created, deleted, started, stopped, monitored,
individually or collectively from a single window, making it easy to stay in control.
The Session Manager stores all configurations in a configuration file. Configurations
can be created saved and reopened using the options in the Session Manager File
menu.
3.1.1 General Properties
When creating a new configuration file you will initially be prompted to enter general
properties.

Figure 4

3.1.1.1 Workbook
A Workbook must be selected.
3.1.1.2 File Store
Select a folder for the filestore. This folder will be used for storing temporary session
files and log files. This might also be a useful location for storing the Session
Manager configuration file, and possibly the workbook.
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3.1.1.3 Data Dictionary
Select an XML document to be used as a Data Dictionary. Standard Data
Dictionaries can be found in the installation directory (e.g. C:/Program
Files/Macdonald Associates/XLFiX/FIX42.xml). The Data Dictionary is used for
determining which messages/tags are parsed to spreadsheets and also for basic
validation of messages. These dictionaries can be changed for your own
implementations using the Data Dictionary Editor (see section 3.2), e.g. for user
defined fields.
3.1.1.4 Logging Level
Select an appropriate logging level for your needs. Normal logging provides minimal
logging (i.e. events, warnings and errors). Detailed logging additionally provides
logging of all messages (outgoing amd incoming). XLFiX recovers FIX messages
from the log each time it is started. If you require this behaviour then select Detailed
logging. Debug logging provides verbose information for debug purposes.
3.1.1.5 Auto Parsing
If you wish XLFiX to automatically parse FIX messages to the selected workbook
then check the AutoParsing checkbox.
3.1.1.6 Enable Filtering
If you wish to enable Excel’s AutoFilter feature on XLFiX’s protected worksheets
then check the Enable Filtering checkbox.
3.1.2 Sessions
XLFiX can be configured to support multiple sessions.

Figure 5

Session properties can be configured for each individual session. The Sessions status
window provides an overview of the status of each session.
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3.1.2.1 Creating a Session
To create a new session, select the Sessions tree node from the tree view on the left
side of the window and then select the Edit->Create menu option. A new session will
be added to the tree. Enter the appropriate properties (see section 3.1.3).

Figure 6

3.1.2.2 Deleting a Session
To delete a session, select the appropriate Session tree node from the tree view on the
left side of the window and then select the Edit->Delete menu option.
3.1.2.3 Starting a Session
To start a session, select the appropriate Session tree node from the tree view on the
left side of the window and then select the Control->Start menu option. To start all
sessions, select the Sessions tree node and then select the Control->Start All menu
option.
3.1.2.4 Stopping a Session
To stop a session, select the appropriate Session tree node from the tree view on the
left side of the window and then select the Control->Stop menu option. To stop all
sessions, select the Sessions tree node and then select the Control->Stop All menu
option.
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3.1.3 Basic Session Properties
3.1.3.1 FIX Version
The FIX version is determined by the Data Dictionary. The BeginString is
automatically selected when you select a Data Dictionary.
3.1.3.2 TargetCompID
Enter the computer ID for the FIX partner you wish to connect to in TargetCompID
text box. The TargetCompID is a string that identifies the FIX partner you are
establishing a connection with (e.g. “FixGateway”) and is provided by the FIX
partner.
3.1.3.3 SenderCompID
Enter your own computer ID in SenderCompID text box (e.g. “FixClient1”). The
SenderCompID is a string that identifies your XLFiX instance and must be agreed
with the FIX partner you are establishing a connection with.
3.1.3.4 Data Dictionary
Session properties can select a separate Data Dictionary. If a Data Dictionary is not
selected for the session then the Data Dictionary in general properties will be used.
3.1.3.5 Connection Type
Select the Connection Type by specifying whether you will be the acceptor or
initiator of the connection.
3.1.3.6 Acceptor Host
Enter the host name or IP address of the acceptor in Acceptor Host. If your instance of
XLFiX is using a Connection Type of initiator then the Acceptor Host will be set to
the host name or IP address of the machine you are connecting to. Otherwise it will be
the host name or IP Address of your PC.
3.1.3.7 Acceptor Port
Enter the port used by the acceptor in Acceptor Port. Avoid using a port reserved for
other services.
3.1.3.8 Resend Possible Duplicates
Check the Resend Poss Dups checkbox if you want to allow possible duplicate
messages to be automatically resent to the counterparty.
3.1.3.9 Next Incoming/Outgoing SeqNum
The next sequence number for incoming/o utgoing messages is shown in the Session
Properties form. This can be changed or reset prior to starting a session, however, this
should only be considered in exceptional circumstances for resynchronisation
purposes, or for manually resetting the session.
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3.1.4 Advanced Session Properties
3.1.4.1 Start Day / End Day
For sessions that span more than one day, select an appropriate Start Day and End
Day. If a session is scheduled to run for a single day or less, use a value of “Any”.
3.1.4.2 Start Time / End Time
Enter the Start Time and End Time in the format “hh:mm:ss”. The initiator of the
connection will only remain connected between these times.

Figure 7

3.1.4.3 Reconnect Interval
The Reconnect Interval is the number of seconds XLFiX will wait before attempting
to reconnect (only relevant to the initiator of the connection).
3.1.4.4 Heartbeat Interval
The Heartbeat Interval is the maximum number of seconds between FIX messages.
3.1.4.5 Logon Timeout
The Logon Timeout is the number of seconds XLFiX will wait for a Logon response
before closing the socket (only relevant to the initiator of the connection).
3.1.4.6 Socket Reuse
Check the Socket Reuse option if you would like XLFiX to start even if the socket is
still in the Time Wait state from a previous connection (only relevant to the acceptor).
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3.1.4.7 Reset on Logout
For sessions that must be reset on logout, check the Reset on Logout checkbox.
3.1.4.8 Reset on Disconnect
To automate resetting a session on disconnect, use Reset on Disconnection.
3.1.4.9 TCP No Delay
Check the TCP No Delay checkbox if you want to disable the use of the nagle
algorithm on the socket.
3.1.5 Specifying Additional Administration Tags
Optionally select a range containing additional admin tag values as shown in Figure 8.

Figure 8
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3.1.5.1 EMX Certificate
Select an EMX certificate when connecting to EMX, otherwise select “N/A”. This
will result in a Certificate tag being added to the Logon message and the DigSignature
and SignatureTime tags being added to Application messages.

Figure 9
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3.1.6 Monitors
XLFiX can be configured to monitor selected log files and parse any FIX messages to
spreadsheets in real-time, in much the same way as for active sessions.
3.1.6.1 Creating a Monitor
To create a new session, select the Monitors tree node from the tree view on the left
side of the window and then select the Edit->Create menu option. A new monitor will
be added to the tree.

Figure 10

3.1.6.2 Deleting a Monitor
To delete a monitor, select the appropriate Monitor tree node from the tree view on
the left side of the window and then select the Edit->Delete menu option.
3.1.6.3 Starting a Monitor
To start a monitor, select the appropriate Monitor tree node from the tree view on the
left side of the window and then select the Control->Start menu option. To start all
monitors, select Monitors tree node and then select the Control->Start All menu
option.
3.1.6.4 Stopping a Monitor
To stop a monitor, select the appropriate Monitor tree node from the tree view on the
left side of the window and then select the Control->Stop menu option. To stop all
monitors, select Monitors tree node and then select the Control->Stop All menu
option.
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3.1.7 Monitor Properties
3.1.7.1 FIX Version
The FIX version is determined by the Data Dictionary. The BeginString is
automatically selected when you select a Data Dictionary.
3.1.7.2 TargetCompID
Enter the computer ID for the FIX partner you wish to connect to in TargetCompID
text box. The TargetCompID is a string that identifies the FIX partner you are
establishing a connection with (e.g. “FixGateway”) and is provided by the FIX
partner.
3.1.7.3 SenderCompID
Enter your own computer ID in SenderCompID text box (e.g. “FixClient1”). The
SenderCompID is a string that identifies your XLFiX instance and must be agreed
with the FIX partner you are establishing a connection with.
3.1.7.4 Data Dictionary
Session properties can select a separate Data Dictionary. If a Data Dictionary is not
selected for the session then the Data Dictionary in general properties will be used.
3.1.7.5 File name
Select the file that is to be monitored.
3.1.7.6 Archive Folde r
If an archive folder is selected then FIX messages will be parsed to HTML table
format in the specified folder, rather than spreadsheet format. This enables you to
create an easy to read archive of FIX messages.
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3.1.8 Logging
XLFiX maintains a log in the “log” subdirectory of the Filestore. This is automatically
rotated to avoid the log becoming too large. The Log viewer of the Session Manager
allows you to see the last 1,000 lines of the log file (most recent at the top). The
viewer also provides a translation of any FIX messages, this makes it easier to analyse
the logs.

Figure 11

To copy translated fields from the log viewer to the clipboard, select the rows of
interest, right-click and select “copy” from the pop- up menu.
A log() interface is also exposed through VBA allowing the user to add log messages
to the same log file from a macro (see example in Figure 23).
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3.2 Data Dictionary Viewer / Editor
3.2.1 Data Dictionary Editor Window
The Data Dictionary file editor can be started by selecting the XLFiX->Data
Dictionary Editor from the menu. The Data Dictionary Editor window will appear:

Figure 12

3.2.1.1 Opening a Data Dictionary
To open a Data Dictionary, select File->Open from the main menu of the editor and
select the file from the file browser.
3.2.1.2 Saving a Data Dictionary
To save the file, select either File->Save or File->SaveAs from the main menu of the
editor.
3.2.1.3 Creating a Data Dictionary
XLFiX is distributed with the QuickFIX Data Dictionaries and these can be found in
the installation directory for XLFiX. These should be used as the starting point for
creating a new Data Dictionaries. To create a new Data Dictionary, open one of the
standard dictionaries, edit it and save it with a new name (i.e. SaveAs).
3.2.2 Changing the FIX Version
To change the FIX version used, double-click the version node in the Tree view on
the left side of the editor. Then enter the new Major and Minor version numbers in the
input box.
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3.2.3 Messages
3.2.3.1 Creating a Message
To create a message, double-click the “Application Messages” node in the Tree view
on the left side of the editor and the Message dialog box will open:

Figure 13

Specify the Name, MsgType and category (i.e. Admin or Application) of the message.
Select the tags/components from the list box on the right and add them using the left
arrow button. Select the tag/components from the list box on the left and remove them
using the right arrow button. Change the order of the tags by selecting them a moving
them up or down using the up and down arrows.
3.2.3.2 Vie wing a Message
Select the message node from the tree view on the left side of the main editor, the
fields will be displayed in the list view on the top right of the main editor. Expand the
message node to reveal nodes for components and groups contained in this message.
3.2.3.3 Changing a Message
To change a message, double-click the message node in the tree view on the left side
of the main editor and the Message dialog box will open (see Figure 13). Change the
message in the same way as for creating a new message (see section 3.2.3.1). To
change the name of a message select the message node from the tree view and then
enter the new name in the text box at the top of the main editor window.
3.2.3.4 Deleting a Message
To delete a message, right-mouse-click on the message node in the tree view and
select Delete from the context menu.
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3.2.4 Components
3.2.4.1 Creating a Component
To create a component, double-click the “Components” node in the Tree view on the
left side of the editor and the Component dialog box will open:

Figure 14

Specify the Name of the component. Select the tags/components from the list box on
the right and add them using the left arrow button. Select the tags/components from
the list box on the left and remove them using the right arrow button. Change the
order of the tags by selecting them a moving them up or down using the up and down
arrows.
3.2.4.2 Vie wing a Component
Components are displayed in red. Select the component node from the tree view on
the left side of the main editor, the fields will be displayed in the list view on the top
right of the main editor. Expand the component node to reveal nodes for other
components or groups contained within this component.
3.2.4.3 Changing a Component
To change a component, double-click the component node in the tree view on the left
side of the editor and the Component dialog box will open (see Figure 14). Change
the component in the same way as for creating a new component (see section 3.2.4.1).
To change the name of a component select the component node from the tree view
and then enter the new name in the text box at the top of the main editor window.
3.2.4.4 Deleting a Component
To delete a component, right- mouse-click on the component node in the tree view and
select Delete from the context menu.
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3.2.5 Repeating Groups
3.2.5.1 Creating a Group
To create a Repeating Group, first make sure that you have created the field (see
section ) that will be used for the number- in-group (e.g. NoMDEntryTypes). Then
right- mouse-click on the node (message, component, or group) to which you want to
add the new group, and select Create->Group from the context menu:

Figure 15

Specify the Group Name by selecting the number- in-group field (e.g.
NoMDEntryTypes). Select the tags/components from the list box on the right and add
them using the left arrow button. Select the tags/components from the list box on the
left and remove them using the right arrow button. Change the order of the tags by
selecting them a moving them up or down using the up and down arrows.
3.2.5.2 Vie wing a Group
Repeating Groups are displayed in blue. Select the group node from the tree view on
the left side of the main editor, the fields will be displayed in the list view on the top
right of the main editor. Expand the group node to reveal nodes for other groups or
components contained within this group.
3.2.5.3 Changing a Group
To change a group, double-click the group node in the tree view on the left side of the
main editor and the group dialog box will open (see Figure 15). Change the group in
the same way as for creating a new group (see section 3.2.5.1).
3.2.5.4 Deleting a Group
To delete a group, right-mouse-click on the group node in the tree view and select
Delete from the context menu.
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3.2.6

Fields

3.2.6.1 Creating a Field
To create a field, double-click the
“Fields” node in the Tree view on the
left side of the editor and the Fields
dialog box will (see Figure 16 ). Enter
the tag name and number, specify the
data type, and then hit OK.
Figure 16

3.2.6.2 Vie wing Fields
Fields for the selected tree node are displayed in the list view on the top right corner
of the main editor window.
3.2.6.3 Changing a Field
To change a field, double-click on the
field in the field list view and the
Fields dialog box will open (see
Figure 17). Change the tag name,
number, or data type, and then hit OK.
3.2.6.4 Deleting a Field
To delete a field, right-mouse-click on
the field in the field list view and
select Delete from the context menu.

Figure 17

3.2.6.5 Required and Implemented Fields
FIX specifies certain fields as “Required”. These fields are identified in the Data
Dictionary with a “required” attribute (shown as “Req’d” in the editor, see Figure 18).
Similarly not all fields defined in the standard specification need to be implemented.
Fields that have been implemented can be identified with the “implemented” attribute
(shown as “Impl’d” in the editor, see Figure 18).

Figure 18

These values can be changed by right-clicking on the field and selecting “Toggle
Required Status” or “Toggle Implemented Status”. Imple mented fields are used as
the basis for creating the message spreadsheets.
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3.2.7 Field Values
3.2.7.1 Creating a Field Value
To create a Field Value, right- mouse-click on the field to which you want to add the
new value, select Create Value from the context menu and the Field Value dialog box
will open:

Figure 19

Enter the value and description, and then hit OK.
3.2.7.2 Vie wing Field Values
Select the field from the field list view in the main editor, the values will be displayed
in the value list view, on the bottom right of the main editor.
3.2.7.3 Changing a Field Value
To change a field value, double-click on the value in the value list view and the Field
Value dialog box will open:

Figure 20

Change the field value or description and hit OK.
3.2.7.4 Deleting a Field Value
To delete a field value, right- mouse-click on the field value in the value list view and
select Delete from the context menu.
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4 Parsing of FIX Messages
4.1 Automatic Sheet Creation
If you check AutoParsing in the general properties then XLFiX automatically creates
sheets for each message with “implemented” fields (see section 3.2.6.5). The XLFiX
message sheets show all messages sent and receive by XLFiX. A separate sheet is
created for each message and each group implemented. They will contain named
ranges based on the names of the FIX message and corresponding groups. The sheets
are created based on the fields “implemented”, as defined in the Data Dictionary (see
section 3.2.6.5).

Figure 21

The columns spanned by the XLFiX named ranges are locked and protected to avoid
accidental changes. However, other columns on these sheets are unlocked and
editable.
Changes to the Data Dictionary selected in the general properties will result in
changes to the sheet when the new general properties are applied (i.e. if you
implement new tags then these tags will be added to the named ranges when the new
general properties are applied)
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4.2 Receiving Messages Using VBA
If AutoParsing is not checked in the general properties then VBA must be used to
process messages sent and received. The following is an example of a Class module
for reading message tables from the queues. The example simply provides an
OnMessage() event function which requests the message table names that have
queued entries, and then receives each batch and logs the field values.

Figure 22

NB: The OnMessage() event only fires for messages that have “implemented” fields
(see section 3.2.6.5).
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The Class can be instantiated and terminated as shown in Figure 23.

Figure 23

Excel Workbook events can be used to instantiate and terminate the message handler
Class. The example code shown in Figure 24 can be adding to the “ThisWorkbook”
module, as.

Figure 24

NB: The message handler class should be terminated before attempting to close Excel.
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5 Sending a message
5.1 Creating a message
To create a message for sending, create a table containing the message data you would
like to send. The first row should contain the tag numbers or field names and
subsequent rows should contain values for the fields (see Figure 25). The first four
fields must be BeginString, MsgType, SenderCompID and TargetCompID (in that
order).

Figure 25

Tables can contain multiple rows of values, making it possible to send batches of
messages.
To make things easier, message templates can be generated from the Data Dictionary
editor. Select the cell where the message template is to start (e.g cell in A1 in Figure
25) then select the message from the tree view in the Data Dictionary editor, rightclick, and select Insert->Message Template… from the context menu (see Figure 26)

Figure 26
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5.1.1 Repeating Groups
Repeating groups are groups of tags that are repeated multiple times within the same
message. The specification of messages containing repeating groups can easily be
viewed with the Data Dictionary editor, e.g in FIX.4.2 the “Allocation” contains a
number of repeating groups, including a nested repeating group (see Figure 27).

Figure 27

For a repeating group it is necessary to ensure that the first tag in each group is the
delimiter tag. An example of a MarketDataRequest message is contained in Figure 28.

Figure 28

Note: nested repeating groups are supported.
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5.2 Sending Messages
5.2.1 Sending a message ad-hoc
Select the range containing the message data, right-click the mouse, and select Send
FIX Message from the context menu (see Figure 29). The message will be added to
the appropriate XLFiX message sheet and sent to the counterparty.

Figure 29

5.2.2 Sending a messages using VBA
XLFiX provides a Send() interface that can be implemented via VBA. The Send()
function allows you to pass an Excel Range to XLFiX. The function returns a Boolean
result.

Figure 30

Alternatively you can pass an object array as an argument to the Send() function.
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6 Connection Status
6.1 Handling Disconnections using VBA
If AutoParsing is not checked in the general properties, and you are therefore using
VBA to handle message events, then you can also use the OnDisconnect() event (see
Figure 31) to handle disconnections.

Figure 31
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6.2 Session Manager
The Sessions status window (see Figure 32) provides an overview of the connection
status for each session.

Figure 32
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